BASICS OF GIS WITHIN QGIS

STEP BY STEP TUTORIAL
# TABLE OF CONTENTS

1. LINKS TO INTERNET DATA SOURCES ................................................................................................ 4

2. DOWNLOAD AND INSTALL QGIS ..................................................................................................... 5

3. BASIC FUNCTIONS OF QGIS ............................................................................................................ 6
   3.1. PRESENTATION OF THE INTERFACE ............................................................................................ 6
       3.1.1. REGISTER YOUR QGIS PROJECT ............................................................................................. 6
       3.1.2. NAVIGATING THROUGH THE PROJECT ...................................................................................... 7
       3.1.3. REDO THE ACCESS PATHS TO THE DATA ................................................................................... 7
       3.1.4. STRUCTURING A QGIS PROJECT ............................................................................................... 8
   3.2. IMPORTING DATA ........................................................................................................................... 9
       3.2.1. OPEN A VECTOR LAYER .............................................................................................................. 9
       3.2.2. OPEN A RASTER LAYER .............................................................................................................. 10
       3.2.3. ORGANISING YOUR LAYERS .................................................................................................... 10
       3.2.4. IMPORT A GPX FILE ............................................................................................................... 10
       3.2.5. IMPORT AN XLS FILE ............................................................................................................. 11
       3.2.6. IMPORT A CSV ...................................................................................................................... 12
       3.2.7. IMPORT THE OPEN STREET MAP BACKGROUND ...................................................................... 13
   3.3. NAPPIES .......................................................................................................................................... 14
       3.3.1. THE ATTRIBUTE TABLE AND SELECTIONS ........................................................................... 14
       3.3.2. ACTIONS ON LAYERS ............................................................................................................ 16
       3.3.3. SAVE A LAYER ....................................................................................................................... 16
       3.3.4. THE LAYER PROPERTIES WINDOW .......................................................................................... 17
   3.4. PROJECTIONS .................................................................................................................................. 17
       3.4.1. PRINCIPLES ............................................................................................................................ 17
       3.4.2. PROJECTIONS IN QGIS ........................................................................................................... 17
       3.4.3. SPATIAL BOOKMARKS .......................................................................................................... 19
       3.4.4. ASSIGN THE same SYMBOLOGY TO a LAYER OF POINTS, LINES AND POLYGONS .......... 20
       3.4.5. DIFFERENTIATE SYMBOLS BY ATTRIBUTE - CATEGORIZED ......................................... 21
       3.4.6. DIFFERENTIATING SYMBOLS BY ATTRIBUTE - SET OF RULES ....................................... 22
       3.4.7. ADDING LABELS .................................................................................................................... 23
       3.4.8. ADD DIFFERENT LABELS ..................................................................................................... 25
       3.4.9. ADVANCED LABELS ............................................................................................................. 25
3.4.10. ADVANCED LABEL POSITIONING ................................................................................................................ 26
3.4.11. ADDING CUSTOM SYMBOLS .......................................................................................................................... 28
3.4.12. ADDING OCHA SYMBOLS .......................................................................................................................... 29
3.5. LAYER STYLE MANAGEMENT ........................................................................................................................... 30
4. EDIT THE DATA .................................................................................................................................................. 32
4.1. EDITING FIELDS ............................................................................................................................................. 32
4.1.1. CREATE AND DELETE A FIELD ..................................................................................................................... 32
4.1.2. USING THE FIELD CALCULATOR .................................................................................................................. 32
4.1.3. EXPRESSIONS ........................................................................................................................................... 33
4.1.4. ATTRIBUTE FORM ..................................................................................................................................... 34
4.2. DATA CREATION: POINTS, LINES, POLYGONS AND SHAPEFILES ............................................................ 35
4.2.1. SWITCHING A LAYER TO EDIT MODE ........................................................................................................... 35
4.2.2. DIGITALISATION OF A POINT IN A LAYER ..................................................................................................... 35
4.2.3. DIGITALISATION OF A LINE IN A LAYER ........................................................................................................ 35
4.2.4. DIGITALISATION OF A POLYGON IN A LAYER ............................................................................................ 35
4.2.5. SNAPPING ............................................................................................................................................... 36
4.2.6. CREATE A NEW SHAPEFILE ......................................................................................................................... 37
5. OTHER USES OF QGIS ........................................................................................................................................ 38
5.1. SOME USEFUL FUNCTIONS .......................................................................................................................... 38
5.1.1. CREATE A PCODE ..................................................................................................................................... 38
5.1.2. LINKING DATA ......................................................................................................................................... 38
5.1.3. MERGING DATA SETS ................................................................................................................................ 41
5.1.4. DOWNLOAD OSM DATA FROM QGIS ....................................................................................................... 42
5.1.5. CREATING CENTROIDS .............................................................................................................................. 43
5.1.6. GEOREFERENCING .................................................................................................................................... 44
5.1.7. ADVANCED SYMBOLOGY .......................................................................................................................... 46
5.1.8. PROPORTIONAL CIRCLES ........................................................................................................................... 46
5.1.9. COLOUR PALETTE ..................................................................................................................................... 46
5.1.10. CROSS-REFERENCING CATEGORISED AND GRADED SYMBOLOGY ..................................................... 47
5.2. SPATIAL ANALYSIS ......................................................................................................................................... 49
5.2.1. STAMP .................................................................................................................................................... 49
5.2.2. SPATIAL QUERY ........................................................................................................................................ 50
5.2.3. KEEP YOUR SELECTION ............................................................................................................................. 51

6. THINKING ABOUT THE LAYOUT OF THE MAP ................................................................................................. 52

6.1. UNDERSTANDING THE PRINT COMPOSER ................................................................................................. 53

6.2. ADDING BASIC ELEMENTS TO A MAP ......................................................................................................... 54

6.2.1. ADD A NEW MAP ..................................................................................................................................... 54

6.2.2. TEXT BOX ................................................................................................................................................ 55

6.2.3. IMAGE ..................................................................................................................................................... 55

6.2.4. ORIENTATION .......................................................................................................................................... 56

6.2.5. SCALE BAR ............................................................................................................................................... 56

6.2.6. LEGEND .................................................................................................................................................. 57

6.2.7. MAKING A LOCATION MAP ........................................................................................................................ 58

6.3. WORKING WITH TEMPLATES ....................................................................................................................... 59

6.3.1. REGISTER A MODEL ............................................................................................................................ 60

6.3.2. LOAD A MODEL ........................................................................................................................................ 60

7. QGIS EXTENSIONS ............................................................................................................................................ 61

7.1. INSTALLING AN EXTENSION ........................................................................................................................ 61

7.2. USEFUL EXTENSIONS .................................................................................................................................... 61

7.2.1. BEGINNER ............................................................................................................................................... 61

7.2.2. ADVANCED .............................................................................................................................................. 62

This publication is supported by the Agence Française de Développement (AFD). Nevertheless, the ideas and opinions expressed in this document do not necessarily represent those of AFD.

The GIS Toolkit is released under a Creative Commons Licence
Attribution - ShareAlike 4.0 International Licence
1. LINKS TO INTERNET DATA SOURCES

Various GIS data websites:

- **Diva-GIS**: [http://www.diva-gis.org/gdata](http://www.diva-gis.org/gdata)
  Various GIS datasets available for direct download or indexing to other sources.

  Good general data resource, datasets on a general level (country) and on a specific environment.

- **GeoBoundaries**: [https://www.geoboundaries.org/index.html#getdata](https://www.geoboundaries.org/index.html#getdata)
  Download administrative boundaries from various sources (OSM, National Statistical Centre)

- **Wikimapia**: [http://wikimapia.org/](http://wikimapia.org/)
  This is an older alternative to OSM, excellent site for finding more datasets of camps and
  neighbourhoods in urban environments. It is a great help for finding local spellings of places in
  an urban environment (using Arabic, Cyrillic or Oriental alphabet for example).

  Download SRTM elevation tiles (raster). They have a resolution of 30 to 60m², with fairly
  accurate elevation data (+/- 2m)

- **GeoFabrik**: [https://download.geofabrik.de/](https://download.geofabrik.de/)
  Download comprehensive OSM data (boundaries, hydrography, roads...) by country, or selected
  area

  UN data related to food and food security

GIS websites of humanitarian partners:

- **HDX website**: [http://docs.hdx.rwlabs.org/](http://docs.hdx.rwlabs.org/)
  Main site for sharing data between partners. Excellent source for administrative borders.

  GIS data site created by UNHCR focusing on camps and refugees.

  GIS data site created by WFP.

- **Sources to old military maps**: [http://www.lib.utexas.edu/maps](https://www.lib.utexas.edu/maps) (US) and
  [http://maps.vlasenko.net/soviet-military-topographic-map](http://maps.vlasenko.net/soviet-military-topographic-map) (soviet)
  Not very recent but sometimes one of the only sources for some remote areas.

- **Geonames**: [http://www.geonames.org/](http://www.geonames.org/)
  A bit complicated to use but very complete database of villages around the world. Be careful as
  some places may be very old / unverified / not very accurate.

- **ACLED**: [https://www.acleddata.com/data/](https://www.acleddata.com/data/) Conflict Identification and Location of Security
  Events.

- **World Bank**: [https://datacatalog.worldbank.org](https://datacatalog.worldbank.org) Various data on socio-economic indicators per
  country

- **Fieldmaps**: [https://Fieldmaps.io](https://Fieldmaps.io) Centralisation of administrative boundaries on a global scale
DON’T FORGET!

Humanitarian organisations work “where others do not go”. It is normal that some areas are poorly or not at all documented and require research. Searching for GIS data can be a full-time job. Don’t hesitate to contact us, we may have some good data already available or that we are working on.

2. DOWNLOAD AND INSTALL QGIS

Go to https://www.qgis.org/fr/site/forusers/download.html to install QGIS.

Prefer the long term version, via the standalone installer. Run the installation file and follow the default installation steps.

To open QGIS, run QGIS desktop with GRASS.
3. BASIC FUNCTIONS OF QGIS

3.1. PRESENTATION OF THE INTERFACE

1. Menu bar
2. Toolbar
3. Layer panel
4. Map space
5. Explorer
6. Information bar

Note: If panels are missing, you can add them from the menu View > Panels.

To change the language of the software: Preferences > Options > click on Languages in the left-hand menu > check Force system nationality and choose your language from the drop-down menu.

3.1.1. REGISTER YOUR QGIS PROJECT

Save your work as a QGIS Project: Project > Save > choose the right place to save your project > Name it > click on Save or use the shortcut in the toolbar.

Attention: Don't forget to register your project regularly!

To create a new project: Project > New or use the shortcut in the toolbar.

To open an existing project: Project > Open or use the shortcut in the toolbar.
3.1.2. **Navigating through the project**

The tools underlined in orange are for entity selection.

3.1.3. **Redo the access paths to the data**

If you move and/or rename files / folders that are used in a QGIS project, you may get surprises when you open your project!

QGIS records the path on your computer to each layer used in the project. This window simply lists the layers that it did not find by following the path it had chosen.

To correct this, click on each line one by one, then click on Browse to give the new path to that layer.
Note: The path can be saved as absolute or relative. Relative means "relative to the location of the project file". You may prefer the relative path when the layers and project file can be moved or shared, or if the project is accessible from computers on different platforms.

To set this parameter go to **Project > Project Properties**.

3.1.4. **STRUCTURING A QGIS PROJECT**

It is important to understand how QGIS projects work:

- Only one project file is saved (.qgs/.qgz format)
- The data used in the project is called by the project
- Images (icons, symbols, style files...) are also called by the project

**Warning:** Sharing a QGIS project file alone does not give access to the data in it: any sharing of a project must be done WITH the data and any other resources used by it.

The best way to structure your projects and work in QGIS is therefore to create a parent folder which will host all the data used by this project. Specifying a relative path in the data access (see part 4.1.2) will ensure that anyone using this folder will be able to open the project with the data without any problems.
3.2. Importing Data

Different data formats can be imported into QGIS.

3.2.1. Open a vector layer

There are several ways to open a vector layer (.shp, .gpx, .kml) in QGIS:

- Use the Data Source Manager button > in the window that opens, select the vector format in the left panel > click on ... to browse your files locally.

- Layer > Add layer > Add vector layer.
- Use **Explorer > Search for data in folders on your computer**, then simply drag it to the map space, or right click on the layer > **add to project**.
- Drag and drop a **.shp file** from your Windows Explorer.

### 3.2.2. **Open a raster layer**

There are two ways to add a raster layer in QGIS:

- Use the **Data Source Manager** button > in the window that opens, **select the raster format in the left panel** > **click on ... to browse your files locally**.
- Layer > Add layer > Add raster layer.
- Use **Explorer** > Search for data in folders on your computer, then simply **drag and drop** it into the map space.
- Drag and drop a **.shp file** from your Windows Explorer.

### 3.2.3. **Organising your layers**

The different Shapefiles are all different layers, the order in which they appear defines the display on the CRSeen. Change the order to change the display. **Select the layer you want to move** and **drag it up or down in the Layers panel**.

💡 The layers at the top of the layers panel appear in the foreground, conversely those at the bottom of the panel appear in the background.

### 3.2.4. **Import a GPX file**

The procedure for opening a gpx file in QGIS is the same as for any vector layer.

The difference comes in a second step: QGIS proposes to open all the entities contained in the .gpx file whatever its geometry type. They will appear in different layers in the Layers panel.

- **Waypoints**: corresponds to the collected points with their name, type and possibly a description.
• **Tracks**: Lines corresponding to your route.
• **Track_points**: All points taken by the GPS during the trip (interesting attributes such as the time the points were taken, their altitude...).

If you want to be able to edit this layer in QGIS, the GPX file must be saved as a Shapefile.

Right-click on the Waypoints layer > Save as > a pop-up window opens

1. Select the ESRI Shapefile format.
2. Click Browse to choose the location of your folder and give it a name > click Save.
3. Click on OK.

### 3.2.5. **IMPORT AN XLS FILE**

QGIS can read XLS data and can even interpret the coordinates to create points. For this you need to have in your XLS file the Latitude and Longitude coordinates expressed in Decimal Degrees.

To import an XLS file: go to Layer > Add layer > Add spreadsheet layer

**Warning**: Adding a spreadsheet layer is an extension of QGIS and needs to be installed.

If you can't find it, go to Extensions > Install/Manage Extensions > search for the extension "Spreadsheet Layers" > select this extension > click install.

*See also the sub-section *Installing QGIS Extensions* at the end of the document.*

In the new window that opens:
1. Click on Browse to find the xls file.
2. Select the sheet you are interested in.
3. Check the Geometry option (this means that QGIS will have to interpret the Value fields as coordinates to create points).
4. Tell the software in which column the coordinates are located.
5. Select the coordinate system to be used to display your data (WGS84 - EPSG:4326).

3.2.6. Import a CSV

QGIS can read CSV (Comma Separated Values) data and can even interpret the coordinates to create points. To do this you need to have the Latitude and Longitude coordinates in your CSV file expressed in Decimal Degrees.

To import a CSV file:
- Use the Data Source Manager button > in the window that opens, select the raster format in the left panel > click on ... to browse your files locally.
- Layer > Add layer > Add raster layer.

In the new window that opens:
1. **Click on Browse** to find the CSV file.
2. Name you want to give it in the project.
3. **Select the file format**: if the file uses the comma as a delimiter, choose "CSV", otherwise choose "custom delimiters" and set it.
4. Define whether the file contains geometry. If yes, select "point coordinates" and fill in the fields in which the DD coordinates are stored. If no, select "No geometry".
5. Define the projection.
6. Click on Add.

**Warning:** If, when opening the attribute table, you notice that the import was not successful and that all the content is grouped together in a single column, it is because the delimiter chosen is not the right one.

### 3.2.7. **Import the Open Street Map background**

It is possible to import the OSM base map directly into our QGIS project. This function is available by default since QGIS 3.4.

In the file explorer, go to **XYZ Tiles**, and **right-click on the OpenStreetMap data > Add Layer to Project**.
3.3. NAPPIES

3.3.1. THE ATTRIBUTE TABLE AND SELECTIONS

To open the layer in the attribute table, right-click on the layer > Open attribute table or select the layer in the Layers panel and use the shortcut in the toolbar.

It is possible to select items in several ways:

- Selection from the attribute table.

You can select an entity in the table by clicking on the line number, the selected entity appears in blue in the table and in yellow on the map. You can select several elements in the table by using the command: Ctrl and Shift.
Selection from the map

Use the selection tool in the toolbar.

**Note:** The selection only applies to the layer selected in the layer panel on the left.

Selection with a query (based on a field)

Use the **Select by Expression** tool. In the window that opens, we will write a query to apply the selection.

For example, if we want to select primary routes (value 'primary' in the 'type' column), we would use the following query: ‘Type’ = ‘primary’

To do this:

1. **Open the Field and Values section** in the central panel
2. **Double-click on the field to be used** in the query
3. **Click on unique all** to display the values available in this field
4. **Double-click on the value to be used** in the query
5. **Click on Select Features**
3.3.2. Actions on Layers

Different actions on the layers can be done: **Right-click** on a layer to access these actions.

- Zoom in on the layer
- Delete this layer from the map
- Duplicate this layer keeping its symbology
- Define or change the Reference Coordinate System
- Change the style
- Open your attribute table
- Switch to Edit mode
- Save the layer as … (e.g. other format: kml)
- Filter the layer using an expression
- Open the Properties window
- Rename the layer in the project (not the file itself)

3.3.3. Save a Layer

The "Save as" function is regularly useful in QGIS to save a selection, save a layer in another format, etc.

To save a layer, **right-click on the layer > Save As**.

In the window that opens:

1. Choose the format in which to save your layer
2. Click on … to choose where to save the layer and give it a name
3. Choose the projection
4. Check this option if you want to save only your selection in the new layer
5. Uncheck the fields you do not want to keep in the new layer
3.3.4. The Layer Properties Window

To open the Layer Properties window > Right-click on the layer > Properties or double-click directly on the layer.

The Layer Properties window gives you information about the layer, allows you to set symbology, labelling options, etc.

3.4. Projections

3.4.1. Principles

The Earth is a sphere, a map is a plane. Like a peeled orange peel that you cannot lay flat without cutting or stretching it, the surface of the Earth cannot be represented on a flat surface without being distorted.

There are thousands of different “warping” methods for representing the curved surface of the Earth on a flat surface. These are called Coordinate Reference Systems (CRS).

GIS software uses two kinds of reference systems:

- **Geographic Reference Systems** (unprojected data, using latitude and longitude expressed in degrees, unable to calculate an area).
- **Projected Reference Systems** (data are projected onto a flat surface and can be expressed in metres, km, miles...).

Why is this important in HIM?

- Projections are vital for working in metric area / distance units (measurements, buffers...).
- Using incompatible projections will result in incorrect alignment of your data in your GIS software.
- Using incorrect projections can distort countries and give false visual proportions.

3.4.2. Projections in QGIS

We mainly use two CRSs:

- **WGS84** as standard (Geographic; Lat/Long units in degrees; universal but cannot calculate areas)
  - EPGS code 4326.
• **WGS84 Pseudo Mercator** for working with distances and areas (projected, units metres/kilometres, also known as "Web Mercator") - EPSG code 3857

**Note:** we use Mercator for simplicity, but keeping in mind the inherent flaws of this projection (high latitude regions have an exaggerated size). You can find all the projections and their CRS code at [http://epsg.io](http://epsg.io)

QGIS is able to overlay data using different projections by checking the "Enable 'on-the-fly' projection" option in Project > Project properties > CRS tab.

💡 Here you can also select the main projection used in your project.

How to **change the projection in a layer**: Right-click > Save as > click on the icon to change the CRS > Select the new CRS.

- Always be aware of the difference in **data projection**, your **project projection**, and the **units of measurement** at the bottom of your screen!
- The list of projections is **VERY** long; it is quicker to use the Filter option and type in the desired EPSG code.

3.4.3. **Spatial Bookmarks**

Spatial bookmarks allow you to save a geographical area, and then navigate more easily between different areas (e.g. between different countries or regions).

- Click on the "new spatial bookmark" tool in the toolbar.
- Set the spatial bookmark.

1. Enter the **name of the bookmark**.
2. By default the right-of-way is the one in the project view, click on "draw on canvas" to select a right-of-way manually.
3. You can save the **bookmark in the project** so that it remains available there, otherwise you can save bookmarks that can be used on any project by saving in the "user bookmarks".
3.4.4. Assign the same symbology to a layer of points, lines and polygons

In the Properties window go to the Style tab > select the symbol you want > change its colour, size ... > click on OK (or Apply if you want to see the result without closing the window).

A set of styles is proposed by default. You can play with the different parameters that define the rendering (colour, thickness, transparency, etc.).
There are several possibilities for one-off symbols:

- **Ellipse marker**
- **Filled marker**
- **Font marker**: allows you to use an icon font (see section 3.5.7 Advanced labels)
- **SVG marker**: allows you to display images in vector format (QGIS offers a default image bank, but you can import them.
- **Etc.**

### 3.4.5. Differentiate symbols by attribute - Categorized

It is possible to assign a different symbol depending on the values in a field.

For example, we are working on a health structure layer, in which there is a "type" field. We will assign a different symbol to each value in this field (*hospital, health centre, etc.*).

In the Properties window go to the Style tab > in the first drop down menu choose Categorised instead of Single Symbol > select the field that will define your categories > click on Categorise to see the values that your field contains > you can change the symbols and colours > click on OK

1. Choose "Categorised" from the drop-down menu
2. Choose the field that will be used to create the symbol categories
3. Click on Sort to create the categories
4. The symbol and name of each category can be changed
3.4.6. Differentiating Symbols by Attribute - Set of Rules

In some cases the "Categorised" option is not enough, we want to group different types into one category so that only three or four categories are displayed.

On new versions of QGIS (after 3.4), it is possible to do this directly by selecting the categories you want to group > right-click > group.

In the Properties window go to the Style tab > in the first drop-down menu choose Set of rules > click on the green + to add an expression > the Rule Property window opens.

In the Label field, give a name to the category you want to define > in the Filter field write the expression (click "ε" to access the Expression String Builder window) > define the symbology for this category > click OK.

Repeat the operation as many times as there are categories to be created.

1. Choose the Rule-based option
2. Add as many expressions as needed
1. Give a name to the created category
2. Open the Expression Chain Builder
3. Define the symbology of this category

For example, if we have a road layer with a type field, we want to represent it in only 4 categories, we will use the following rules:

- The **main roads**
  
  "type" = 'unclassified' OR "type" = 'primary' OR "type" = 'tertiary'

- **Other roads**
  
  "type" = 'residential' OR "type" = 'service'

- The **tracks**
  
  "type" = 'track' OR "type" = 'cycleway'

- The **rest**

  "type" = 'path' OR "type" = 'pedestrian' OR "type" = 'footway'

  - Or specify the "Else" function, which means: everything **ELSE** else

### 3.4.7. Adding Labels

In the **Properties** window go to the **Labels** tab > select Show labels for this layer from the drop down menu > select the field to be used as a label > change any settings you wish to achieve the desired result.
1. Select the **Show labels for this layer** option
2. Select the field to be used as a label
3. Preview of the label rendering
4. All the parameters that can be varied to modify the rendering of the label

- **Text**
  - Defines the style of the text such as font, size, colour ...

- **Formatting**
  - Allows you to split your label into two lines using a character and defines the spacing between the lines.

- **Buffer**
  - Allows you to add a buffer (halo) around the text to easily differentiate it from the background.

- **Background**
  - Allows you to add a background to the text (e.g. frame the text)

- **Shadow**
  - Adds a shadow behind the text

- **Placement**
  - Defines the location of the label according to the shape (centroid, perimeter ...)

- **Rendering**
  - Additional options: visibility according to scale, limit on the number of labels to be displayed, obstacles
3.4.8. **ADD DIFFERENT LABELS**

As with symbols, it is possible to assign different labels within the same layer. For this we will also use expressions.

This is a common practice for naming cities, for example, labelling the country's capital in a large bold font size and other cities in a smaller font.

In the Layer Properties window, go to the **Labels** tab > select Rule-based labels > click the green + to add an expression > the Rule Properties window opens.

Follow the same steps for the symbols in the Rule Set.

3.4.9. **ADVANCED LABELS**

It is possible to set up labels with personalised texts, according to different fields.

1. Select the symbol to open the "expression calculator"
1. Shortcuts to logical connectors / arithmetic elements
2. Expression area
3. Functions / Fields

From the **expression calculator**, it is possible to build the expression that will allow to fill our label. It is possible to insert several fields, fixed text...

- Fields are **enclosed in inverted commas (" ")**, text in apostrophes ("').
- Each added item is **preceded by a '+'**.
- The '/n' sign indicates a **line break**

### 3.4.10. Advanced label positioning

In the case of advanced labels with a lot of text, it is possible to manage the positioning of these labels manually.

To do this, simply select the "move a label or diagram" button on the "labels" toolbar.

You can then **manually select and move the labels.**
1. It is then possible to link them to their reference entity using the "connectors" tab
2. Check "Draw connectors".
3. The style of the connector is configurable
4. The anchor point can also be indicated.

Overview:
3.4.11. Adding Custom Symbols

Temporarily:
With this method, the custom SVG symbol will only be added to the current project.

In the Layers panel, double-click on the symbol you want to change > click on Simple Symbol > In the top right drop-down menu, change to 'SVG Symbol' > click on "..." to search for the icon on your computer > click on Open > Click on OK.

Permanently (will always be available in the QGIS SVG library):

- Go to C:\Program Files \QGIS 3.XXapps\qgis-ltr\svg.
- Create a "Personal Icons" folder here.
- Paste the custom SVG icons of your choice here.
Then, in QGIS, in the Layers panel:

- Double click on the symbol to be changed
- Click on Simple Symbol
- In the top right drop-down menu, change to 'SVG Symbol'.
- Look for the "My Personal Icons" folder in the "SVG Groups" list
- Your icon is now automatically available, select it
- Click on OK.

**REMINDER!**

You can only add custom icons in SVG format (JPG, PNG, etc. are not accepted by QGIS).

You can recreate your icons in a graphic design software (Illustrator, etc.) or download new ones for free from the Noun Project website: https://thenounproject.com/

### 3.4.12. Adding OCHA Symbols

Before installing OCHA symbols, we need to install the corresponding fonts.

You can download the OCHA icon font proposed by MapAction at the following address

1. **Install the font** (.ttf format)
2. **Import the .xml file into QGIS** (steps below)
   i. Go to Preferences > Symbol Manager.
ii. Click on Import/Export at the bottom left

iii. In the Import Symbol(s) window click Browse to search for a style on your computer (then click OK).
Select the file: humanitarian-icons-v2-1-qgis-ttf.xml

iv. Choose the style > Click on Select All > click on Import > close the Symbol Manager.

3.5. Layer style management

Layer styles allow you to keep the properties of a layer, whether in terms of data management (field validation, field type), projection, or symbology.

This ensures efficient layer management, especially on sample data that can be reused in different projects:

- Administrative boundaries
- POI / Locations
- ACLED data

In the property window of a layer, a style button is always visible at the bottom left, it allows to manage styles.
Once changes have been made to a layer, such as a categorised symbology and the application of particular icons/colours

Click on the **style** button > **Save style**

1. Specify a path to save the layer
2. Select the properties you wish to save. By default, everything is checked, but you can choose to keep only the symbology for example.

Importing a style is done in the same way as exporting, by selecting **style > load a style**, then indicating the properties to be taken into account and
4. EDIT THE DATA

4.1. EDITING FIELDS

4.1.1. CREATE AND DELETE A FIELD

To create or delete a field in your attribute table you need to be in edit mode, click on the Switch to edit mode button.

To create a field, click on the Add a field button > fill in the information requested in the pop-up window > click on OK.

To delete a field, click on the Delete Field button and then select the field you want to remove (you can select more than one) > click on OK.

Once you have finished, click the Switch to edit mode button again and save or discard your changes. Once saved, the changes are final (deleted fields cannot be recovered).

4.1.2. USING THE FIELD CALCULATOR

The field calculator allows you to:

- Calculate the values of a field from a predefined function: area, identifier, ...

Example: calculation of the area in km² → $area / 100000$

- Calculate the values of a field from a formula between several fields: population density, attack rate, ...

Example: calculation of the population density → "POPULATION EST" / "Area km2"

- Completing the values of a field automatically:

Example: fill in the 'editby' column with its name → 'Marie'

💡 The field calculator can be applied either to a complete field or just to a selection of items in a field.
Expressions use SQL to filter data in a layer, make a selection based on a field or create a set of rules to define categories used for symbology and labels.

Some basic expressions:

- **Equal to**: select entities that have a specific field equal to a value.
For example, select admin 2 which is "Mass Shelter".

- **Larger / smaller than**: Select entities that have a specific field larger or smaller than a value

For example, select the admin 2s that have an area greater than or equal to 0.000005.

```
"Shape Area" >= 0.000005
```

- **Concatenation**: Useful for creating a label composed of several fields.

For example, you want to display the name of each block and its type in the label.

```
"name" || ':' || "type_bloc"
```

### 4.1.4. ATTRIBUTE FORM

The use of the "Attribute Form" properties of a layer allows to ensure a field format for the layer. That is to say, a list of predefined values, a date format, a checkbox, etc. can be assigned.

This use is particularly relevant to ensure that the field values are properly encoded so that the symbology is applied correctly, and thus avoid typing errors (accent, capitalization, extra space, etc.).

To set up the attribute forms:

1. **Attribute form tab**
2. **Field to be set**
3. **Selection of form type** (here map values, list can also be used)
4. **Enter the values** manually or load them from your layer
5. If any data has no values, remember to add the value "NULL" as an option.

If a symbology is related to these specified values, then it is worth saving the layer style, so that it can be easily reused later (see section 3.6 Managing layer styles above).
### 4.2. DATA CREATION: POINTS, LINES, POLYGONS AND SHAPEFILES

#### 4.2.1. SWITCHING A LAYER TO EDIT MODE

- First select the desired layer (in blue) in the Layers panel.
- Then click on the Edit shortcut button (yellow pencil) in the toolbar (or right-click > Switch to edit mode).

This button can also be accessed directly in the attribute table.

If you then click on the yellow pencil icon again, you will deactivate the editing mode. You will then be asked if you want to save your changes (be careful before confirming).

#### 4.2.2. DIGITALISATION OF A POINT IN A LAYER

1. Switch to edit mode
2. Create a new entity
3. Moving an entity
4. Delete an entity

Create a new point: Use the "Create a new entity" button > left-click on the map > enter the attributes > click OK > a new point is created.

#### 4.2.3. DIGITALISATION OF A LINE IN A LAYER

The method is similar to digitising a point (see above). Only the fourth icon changes slightly: this one corresponds to "Create a new line".

Use the "Create new line" button and click several times on the map (left button) to draw the different parts of your line. When this is done, right-click to complete your line and access the Attributes window.

> Complete the attributes and click OK.

#### 4.2.4. DIGITALISATION OF A POLYGON IN A LAYER

The method is similar to digitising a point or a line (see above). Only the fourth icon changes slightly: this one corresponds to "Create a new polygon".
Use the 'Create new polygon' button and click several times on the map (left button) to draw the different parts of your polygon. Once done, right-click to finish your polygon and access the Attributes window.

> Complete the attributes and click OK.

4.2.5. SNAPPING

When digitising, it can be useful to activate the snapping tool, which allows to create perfect connections between entities.

To use the snapping tool you need to add a toolbar that is not available by default. To do this, right-click in the grey toolbar area. In the menu that opens, select Snapping Toolbar.

A new toolbar appears.

To activate this option when you digitise, simply click on the magnet. You can then set some options. Allows you to choose which layer you want to latch onto (= "magnetise") when digitising.
Allows you to choose which element of the layers you will latch onto (= "magnetise") when digitising, the nodes and/or segments.

Defines the distance from which our cursor will cling (= "magnetise") to nodes and segments.

### 4.2.6. CREATE A NEW SHAPEFILE

If you want to create a new blank Shapefile: > Go to Layer > Create Layer > New Shapefile or use the shortcut button

1. Select the type of geometry to create
2. Select the coordinate system

The following steps concern the creation of fields in this new layer, repeat as many as necessary, but it is possible to add other fields afterwards.

3. Name the field
4. Select the field format (text, integer, decimal, ...)
5. Enter the length (no. of characters) and the precision of the field (no. of decimals)
6. Click on Add to add it
7. Click on OK and then choose where to save the layer and what to call it.

The new layer is added to the map.
5. OTHER USES OF QGIS

5.1. SOME USEFUL FUNCTIONS

5.1.1. CREATE A Pcode

💡 The Pcode is a unique identifier useful for, for example, linking external data.

For this exercise, we will create a Pcode for the tap layer. The format of this Pcode will be "tap...".

To create a Pcode in your layer: open the attribute table > open the Field Calculator.

1. Check “Create a new field”.
2. Name this field “Pcode”.
3. Choose “Text” as Type
4. Enter the expression “’tap’ | $id” This expression concatenates the word “tap” and the identifier for the entities in this layer
5. Click on OK

5.1.2. LINKING DATA

A very useful feature of GIS is the ability to transform external data from spreadsheets into geographic features. We will add fields to the attribute table with data from an Excel or CSV file.

To do this, it is IMPERATIVE to have a column in common between your two files (spreadsheet and Shapefile).
Context of the exercise:
- QGIS data: taps layer of the camp
- Excel data: spreadsheet with the status of each tap

We will link these two data files using a common field: `pcode`.

To link the Excel spreadsheet to our layer, we first need to add the spreadsheet to our QGIS project:

> Go to Layer > Add Layer > Add Spreadsheet Layer or use the shortcut

> Check the "Detect end of file" option

To link the spreadsheet to the top layer: open the **Layer Properties** window and go to the Joins tab:

1. Click on the **green + button** > a window opens
2. Enter which spreadsheet you want to link to this layer
3. Enter which field in this spreadsheet will be used as the common column
4. Enter which field of this layer will be used as a common column
5. and 6. Click on Ok in both windows

Look at the top layer of the attributes table, you will see that the status of the field has changed:
5.1.3. Merging Data Sets

It is possible to merge different files, either shapefiles or GPX files. This can be useful to bring together data collected by several people in the field and end up with one common file.

💡 In the case of using an application that does not allow synchronization to a central database, the merging of datasets from different devices will have to be done manually via QGIS.

Remarks:

It is easier to merge data sets when they have the same structure (same fields, same categories, etc.). It is therefore preferable to think about this before collection in order to configure the devices and train the collectors in the same practices.

Merging can only be done between files with the same geometry.

To perform the merge, look for the "Merge" tool in the QGIS tools search bar.

In the window that opens:
1. Click on ... to select the layers you want to merge
2. Select the layers and click on OK
3. Define the projection
4. By default, a temporary layer will be created, if you want to save it right away, click on ...
5. Click on "Run in Background" to launch the tool

Once the merging process is complete, you can close the tool window, and you will see that a new "Merged" layer has appeared in your QGIS workspace.

Remarks:

Once the files have been merged, it may be necessary to harmonize (= clean up) them. This step is crucial in the case of merged files to avoid duplicate categories when styling your data by category.

You can also add or remove fields.

→ Refer to Part 4: Editing the data.

5.1.4. Download OSM data from QGIS

It is possible to download OSM data directly from QGIS. For this, we will use an extension called QuickOSM.

To open this tool, go to Vector > QuickOSM or use the shortcut button in the toolbar.

1. Select the category of data you wish to download
2. Select the sub-category of data you wish to download
3. Choose the right-of-way according to which you will download the data
4. View and run the query

The layers then appear in your project, but are temporary layers. You will need to save them to keep them.
5.1.5. Creating Centroids

Go to Vector > Geometry Tools > Polygon Centroids.

In the window that opens:

1. Select the layer for which you want to create the centroids
2. By default, a temporary layer will be created, if you want to save it right away, click on ...
3. Click on Run in Background to launch the tool

As centroids are calculated as the orthocentre of each polygon, it is possible that points fall outside of some oddly shaped polygons (with obtuse, or "banana-shaped" angles). If you wish to correct this, switch to edit mode and move the points outside.
5.1.6. Georeferencing

Before starting georeferencing, check that your project is in WGS 84! (Project > Project properties > SCR)

Georeferencing allows you to give coordinates to a raw image. It can also allow you to correct coordinates and distortions.

To correct the coordinates and distortions, we will use the Georeference tool. Go to Raster > Georeference > Georeference.

Open the image in this window by clicking on File > Open Raster ... > find your image > Open.

The image "...verywrong.TIF" is not yet georeferenced and therefore opens in the wrong place.

Note: If you open an image that does not have coordinates (this one does, they are just wrong), you will have to tell the software which projection to use. In this case, select the same projection as our QGIS project: WGS 84.

Now open the Georeference tool (Raster > Georeference > Georeference).
Click on a specific point on the image in the Georeferencing window, a pop-up window will open.

We will now assign coordinates to this point. To do this we can enter the coordinates directly into the X and Y fields (for GPS points for example) or use the map canvas: **click on From the map canvas > click on the same position (be as precise as possible) > click on OK.**

To georeference the image correctly, create at least 6 GCP points spread over the map (GCP = Georeferencing Control Point).

The georeferencing parameters allow you to define the projection, name and location of the image that will be georeferenced.

In reality, you cannot really modify a non-georeferenced image: by giving a new name to the image in Settings/Output Raster, **you create a copy, a new image that will be georeferenced appropriately.** You can then remove the old image, which is still badly placed and no longer useful.

Once you have created enough points well distributed on the map and chosen the parameters, **click on File > Start Georeferencing > a pop-up window will open showing the progress.**

Do not close the Georeferencing window. If you keep it open, you will be able to add more PCGs or edit those you have previously created, in order to improve the georeferencing.
When the progress is finished, open the georeferenced image in your QGIS project. To see if it overlays correctly with your background map, play with the opacity level of your layer (Properties > Style tab > Transparency).

If you are not satisfied with the result, you can add, edit or even delete PCGs. **Click again on Start Georeferencing to refresh the main project.**

### 5.1.7. Advanced Symbology

**Reminder of the mapping rules.**

Population data can be represented in two ways:

- With raw population figures (example: 8170 inhabitants)
- With population densities (example: 320 inhabitants/km²)

Raw numbers are represented as proportional circles and densities as colour patches - **the reverse is not an option!** (never raw numbers in colour patches).

### 5.1.8. Proportional Circles

It is only possible to generate proportional circles in QGIS on point layers. If you want to represent proportional circles from a polygon layer, you must first generate the centroids of your layer.

**Go to Properties > Style tab > choose Graduated** from the top left drop-down menu.

1. Select Graduated
2. Select the field to be represented
3. Select the symbol to be used
4. Select Size as the method
5. Define the classification parameters and click on Classify
6. Click on OK

### 5.1.9. Colour Palette

The gradient representation is only used to display rates on a map.
If you need to calculate a rate based on two fields, refer to the section Using the field calculator.

**Go to Properties > Style tab > choose** Graduated from the top left drop-down menu.

1. Select Graduated
2. Select the field to be represented
3. Select Color as the method
4. Choosing a colour gradient
5. Define the classification parameters and click on Classify
6. Click on OK

### 5.1.10. CROSS-REFERENCING CATEGORISED AND GRADED SYMBOLOGY

Sometimes you may want to **apply a double symbology** to certain data, such as crossing a representation by category and by size.

An example is the ACLED data (see section 1. Links to internet data sources), where we obtain a layer of security event points. One can then represent:

- A **different colour** for each type of event
- **Size proportional to** the number of victims

This is done by applying a categorised symbology (see section 3.5.3 Differentiating symbols according to a categorised attribute) to the **event_type** field.
1. Go to the layer symbol and **open the size options** > **Click on Wizard**

2. Select field to sort by size

3. Automatically load min and max values

4. Change circle size options

**Apply in the legend**

You can now display in the legend the size of the circles and the types, to do so **go to the symbology** > **Click on advanced** at the bottom of the classification area

You can now set the rendering of the caption that will be added.
5.2. SPATIAL ANALYSIS

5.2.1. STAMP

As the buffer is distance based, we will use the Mercator projection. **Create a new blank project** in which we will do the manipulations.

**Set the projection of your new project to WGS 84 / Pseudo Mercator** (Project > Project properties > SCR > check Enable ‘on-the-fly’ projection > type the EPSG 3857 code in the Filter). To create the buffer, the input layer also needs to be in WGS 84 / Pseudo Mercator, open the **Tap** layer used previously (tza nya taps p_msf.shp).

To create a buffer: **go to Vector > Geoprocessing Tools > Buffer(s)** > a pop-up window opens.
5.2.2. **Spatial Query**

We can use Spatial Query to select shelters that are located more than 250m from a tap (using the buffer we just generated).

For this operation, we will use the Spatial Query tool.

Go to **Vectors > Search Tools > Spatial Query** > a pop-up window opens.

1. Select the layer to which the stamp will be applied.
2. Enter the distance used (e.g. 250) for the buffer radius (in metres)
3. Define the location and name of the Shapefile that will be created
4. Click on OK.
You can easily reverse your selection if you want to emphasise shelters that have difficult access to a tap outside the buffers by simply using this tool in the attribute table.

5.2.3. KEEP YOUR SELECTION

The selections are temporary. You can make this information permanent in two different ways: by exporting the selected entities to a separate layer or by adding a field in the current layer while specifying the selected entities or not (in or out of the buffer).

**Save your selection in a separate layer:**

Refer to the Save a layer section, ensuring that the Save only selected features option is selected.

**Transform your selection into field attributes**

We will use the Field Calculator as this tool allows us to make calculations on selected entities.

Here we can create a field called `dist_tap` (which means "distance to tap") and the value of this field will be: > 250m or < 250m.

Ensure that shelters that are located outside the buffers are selected (see section 5.2.2 Spatial query above).

Refer to the section Using the Field Calculator using the expression `'> 250 m'` and check that the option "Update only selected ... entities" is checked.

Reverse the selection and redo the calculation (writing "< 250 m") to complete the values of the other entities.
6. THINKING ABOUT THE LAYOUT OF THE MAP

A QGIS project is not a map as such until the layout of the elements (title, legend, etc.) is done. This section focuses on the layout of the elements. Note that the layout is the last step of the processing, you need to have all your analysis and styles done before you can do this final step.

Open a print dialer

1. Go to Project > New Print Composer (a new Map layout) > name it “MY FIRST MAP” > click OK.
2. A new blank document appears

The print composer will be saved with the project, any changes made to it will be saved each time the project is saved. You can find your different typesetters in the Project > Page Setup tab.
6.1. Understanding the Print Composer

1. **Dialer tools** (Save, New, Duplicate, Manager, Add items from template, Save template)
2. **Navigation bar** (zoom, refresh)
3. **Toolbar** (Move, Zoom, Select, Move in map, Add new map / image / text / legend / scale / shape / ...)
4. **Toolbar** (adding elements to the page: map, scale, legend, title...)
5. **Feature panel**: similar to the QGIS layer panel
6. **Advanced options**

**Checklist of the main buttons of the dialer:**

---

First of all, you should always set the size of your map.

- Right-click on the blank map > Page property
- Choose **the size of your document** (A4, A3, A2 ...)

**A4 and A3 are the most commonly used sizes for maps. We will use A4 for this training.**
- Choose the Orientation (Landscape or Portrait)
Notes for later: The Selection tool is used to select items (the caption, title, etc.) Once selected (later), an item will have small handles at the four corners and you can change its properties in Object Properties (in the Properties panel).

6.2. Adding Basic Elements to a Map

6.2.1. Add a New Map

To add a new map, use the button and draw a rectangle on the canvas.

To move items within the map, first select and then use the button to move the items (change the location).

To zoom in on the map, while using the tool, you can press Ctrl + use your mouse wheel (gently!) or change the scale in Object Properties.

The buttons and do not zoom or move within the map, but they do zoom and move the Composer itself. You can select the tool and use the handles to resize the map.
6.2.2. **Text box**

To add text (title, explanations...), use the Add Label tool and draw a rectangle of the desired size.

In the **Object Properties** panel (on the right hand side of the screen) you can enter your text in the text box and change the font, style, colour etc. *(remember to use the scroll bar in the window to see all the options)*.

6.2.3. **Image**

To add an image, use the button and draw a rectangle in the middle of the canvas. In Object Properties, use the button in Image Source to search for your image (for example, to insert a logo).
6.2.4. Orientation

To add a north arrow you can use the button and draw a rectangle at the top corner of the canvas. You can look in the properties, in the arrows folder there is an image bank for default orientation arrows. It is also possible to import an image in vector (.svg) or raster (.png, .jpg...) format to act as an orientation arrow. However, using the icons from the QGIS icon bank ensures that the images are not lost when sharing the project.

6.2.5. Scale Bar

Before adding a scale bar, select your main map and check in the Object Properties that the Scale field has a round number:

<table>
<thead>
<tr>
<th>Scale</th>
<th>Validity</th>
</tr>
</thead>
<tbody>
<tr>
<td>1:500000</td>
<td>✓</td>
</tr>
<tr>
<td>1:2500</td>
<td>✓</td>
</tr>
<tr>
<td>1:1000000</td>
<td>✓</td>
</tr>
<tr>
<td>1:35000</td>
<td>✓</td>
</tr>
<tr>
<td>1:4320989</td>
<td>☐</td>
</tr>
</tbody>
</table>
To add a scale bar, you can use the button and click on the map. In the Object Properties tab, scroll down to the options window and use the following functions to customise your scale bar:

- **Map related to scale**
- **Unit system of the bar** (in metres, miles, degrees ...)
- **Segments on the left**: segments shown before 0 m (always set to 0)
- **Fixed width**: define the width of each segment (here it is 1km but it depends on the scale of your map)
- **Height**: height (thickness) of the ladder bar

There are many other options to customise your ladder bar (change the font, colours ...)

💡 It is possible to select "numeric" in the scale bar properties to display a numeric scale.

### 6.2.6. Legend

Before adding a caption, be sure that:

- All your layers have an explicit name ("rivers", "primary roads" ...)
- You use the final version of your map (no more layers to add, move, rename or modify). You can still modify them later but you will have to redo the legend.

To add a legend, you can use the button and draw a rectangle on the canvas.
In Object Properties, if you keep the 'Auto update' option checked, new layers added to your project will automatically be added to the legend but you cannot control them individually (rename if necessary, etc.).

Once the option is unchecked, you can update the name of the layers, group them, reorganise them...

### 6.2.7. Making a Location Map

Adding a location map in the corner of your map will help locate the area you are viewing on the main map.

QGIS only works with one map at a time, so it is not possible to automatically create a location map, so you have to be a bit tricky to create one:

1. Prepare global / national layers in your project:
   i. Administrative boundaries
   ii. Capitals

2. Inserting a map in the layout manager
   i. Blocking layers in properties
3. Display a rectangle on the extent of your main map (this part requires you to have an add-on to the main map).
   i. Go to Location Map Properties > Previews
   ii. Add a preview and link it to the main map
   iii. Changing the style of the box

**Caution:** This method requires you to be sure that you are not going to modify your location map, as once the layers are locked, they will keep the style, and any updates to them on your project will not affect your location map.

6.3. **Working with Templates**

Using the instructions above we were able to create a map like the one shown below.
6.3.1. Register a model

In order to simplify the task for your future projects, you can save your layout template and reuse it to build your next maps. QGIS templates are pre-made Print Composer templates and will therefore already contain all the elements you have previously configured: title, map, scale, source, etc.

To save your model:

1. Start from the Print Composer and click on the Save as Template tool
2. Choose a name for your template and save it in your workspace. This is a .qpt file

6.3.2. Load a model

To use your model:

Open the Dialer Manager > Project tab > Print Manager

1. Select a specific layout
2. Load the .qpt file
3. Click on Create and enter a name for the dialer
4. The compositor will then be associated with the project and available in this space

When loading an external template, it is often necessary to reposition images, logos and other layout elements. Elements displayed as a red cross indicate that the path is broken.
7. QGIS EXTENSIONS

7.1. INSTALLING AN EXTENSION

QGIS has lots of useful extensions! To install the extensions, you need an internet connection and go to Menu Extension > Install/Manage extensions. Then by scrolling down the list of available extensions, select the one you are interested in and click on the Install Extension button.

It is then possible to search for existing plugins on QGIS (this requires an internet connection). You can find the existing plugins on the official directory: https://plugins.qgis.org/plugins/

7.2. USEFUL EXTENSIONS

7.2.1. BEGINNER

- Spreadsheet layers: https://plugins.qgis.org/plugins/SpreadsheetLayers/
  Importing Excel files (see section 3.2.5 Importing an XLS file)
- QuickMapServices: https://plugins.qgis.org/plugins/openlayers_plugin/
  Allows to display Google/Bing/OSM internet maps in the background (install, then go to Internet Menu > OpenLayerPlugin to choose to add a Bing Imagery, OSM etc... layer) only with an internet connection!
- Autosaver: https://plugins.qgis.org/plugins/autoSaver/
  Plugin that allows to save the project every X minutes.
• **QGIS Resource Sharing:** [https://plugins.qgis.org/plugins/qgis_resource_sharing/](https://plugins.qgis.org/plugins/qgis_resource_sharing/)
  Accessing an open bank of styles (lines, polygons, points)

### 7.2.2. **ADVANCED**

- **Profile Tool:** [https://plugins.qgis.org/plugins/profiletool/](https://plugins.qgis.org/plugins/profiletool/)
  Allows you to obtain a gradient profile
- **Qgis2web:** [https://plugins.qgis.org/plugins/qgis2web/](https://plugins.qgis.org/plugins/qgis2web/)
  This plugin allows you to create an interactive map from a Qgis project. It is efficient even if the
- **QField Sync:** [https://qfield.org/docs/synchronise/qfieldsync.html](https://qfield.org/docs/synchronise/qfieldsync.html)
  Preparation and packaging of QGIS projects to run in QField. Developed by OpenGIS
- **QuickOSM:** [https://plugins.qgis.org/plugins/QuickOSM/](https://plugins.qgis.org/plugins/QuickOSM/)
  Very powerful OSM data download, a bit complex to handle.
  *Please refer to part 8.1 - Integrating and using OSM data in QGIS of the toolkit for a tutorial on how to use this plugin.*
- **Lizmap:** [https://plugins.qgis.org/plugins/lizmap/](https://plugins.qgis.org/plugins/lizmap/)
  Plugin for creating a web map with editing from a QGIS project.
- **MMQGIS:** [https://plugins.qgis.org/plugins/mmqgis/](https://plugins.qgis.org/plugins/mmqgis/)
  Compilation of numerous geoprocessing and spatial analysis tools
- **MapTiler:** [https://plugins.qgis.org/plugins/qgis-maptiler-plugin/](https://plugins.qgis.org/plugins/qgis-maptiler-plugin/)
  Access to free Vector Tiles (requires online MapTiler registration)